Jump to content
Sign in to follow this  
martincl

powershift auto query

Recommended Posts

I have an auto from a 66 Avanti.

When I move the lever on the box to Park, it is `spring loaded' and moves back when I let go. Is this normal? The other powershifts I have from Studebakers don't do this.

Thanks, Leon.

Share this post


Link to post
Share on other sites

 

Look at this page

64chasp251s.jpg

 

It seems spring loaded because it's out of adjustment. Inside the case, there's a flange that looks like a sine wave.  The detent ball/spring for each gear position rides on this  and unless you have the adjustment correct it will not seat correctly, likely forcing the lever in/out of the position you want.  There's another l o n g chance that the transmission was changed out at some time for a Ford built unit.  It's basically the same as the PowerShift, but they use a different arc  on the gear shift geometry.

 

Share this post


Link to post
Share on other sites

Thanks for the suggestion. Funny; I didn't think about it being faulty! I'll open up the box and check out the the detent ball/spring setup.

I did think about the Ford option as I also have a Ford unit that came out of a Stude Avanti. However it has the vacuum modulator and Ford numbers cast into the housing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×